Interframe Подключение Софт Info Magic Фото Почта Карта Нарвы
Пользователь
Забыли пароль? Регистрация
Сейчас на сайте

Пользователей на сайте: 13

2 пользователя, 11 гостей

bombr3s Docent

Уничтоженные гравийные дорожки на променаде - это
Счётчики

LiveInternet

Рейтинг@Mail.ru



Gtk 2.2.2 проблемы :(

#1
Xa
  • Статус: Гуру Общения
  • Сообщения: 175
  • Карма: 0
  • Возраст: 33
  • Пол:
Сабж, что бы его поставить, зависит, кроме всего прочего, от некой pango, и вот я пытаюсь ее поставить. Скачал последнюю 1.2.3. Жму ./configure и он в конце пишет, что нету fontconfig >= 1.0.1, а fontconfig-config --version пишет что она как раз 1.0.1, и что надо fontconfig.pc добавить в pkgconfig, который у меня есть тоже, но вот fontconfig.pc нет. Вот что у меня есть:

debian 3
Xfree 4.3
atk 1.2.4
glib 2.2.2

все остальное что по дефолту ставилось, помогите!!! :)

apt-get install fontconfig тоже ни к чему не приводит

0 пользователя(ей) сказали спасибо:

#2
gabber
  • Статус: Administrator
  • Сообщения: 479
  • Карма: 0
  • Пол:
    Не указано
не надо в дебиан ничего насильно ставить из исходников, так можно всю систему порушить.
не зря же там сделан apt-get и 3 (!) репоизитария пакетов:
stable
testing
unstable

если хочеться совсем свежий софт и траффик не проблема - значит надо ставить unstable

для начала правишь
/etc/apt/sources.list

в нем меняешь все stable на unstable
потом делаешь
apt-get update && apt-get upgrade && apt-get dist-upgrade
и в итоге получаешь рабочую систему со свежим софтом и рабочую систему, да и glibc там уже 2.3.1, так что советую :)

читайте доки они рулез :)
кстати рекомендую подписаться на список рассылки debian-russian@lists.debian.org там и многие другие вещи подробно обсуждаются.
Но перед тем как задавать вопрос - прочитайте архив этого списка рассылки, возможно ваш вопрос уже был задан и на него получен ответ :)

также есть еще http://www.apt-get.org - там можно найти неофициальные репозитории с нужным софтом, например mplayer там есть :)


Linux = RuleZ

0 пользователя(ей) сказали спасибо:

#3
Xa
  • Статус: Гуру Общения
  • Сообщения: 175
  • Карма: 0
  • Возраст: 33
  • Пол:
Габбер, а есть разница, какая страна в sources.list, .ee ,или оригинальная .debiab.org, на них одинаковые unstable пакеты? Т.е. эстонцы своевременно обновляют свой фтп?

0 пользователя(ей) сказали спасибо:

#4
gabber
  • Статус: Administrator
  • Сообщения: 479
  • Карма: 0
  • Пол:
    Не указано
для Эстонии лучше использовать ftp.estpak.ee - быстрое зеркало, если хочеться европейское, бывает не успевают вовремя обновить, тогда лучше ftp.de.debian.org


Linux = RuleZ

0 пользователя(ей) сказали спасибо:

#5
Xa
  • Статус: Гуру Общения
  • Сообщения: 175
  • Карма: 0
  • Возраст: 33
  • Пол:
Ну вот, в unstable нет xfree4.3.0, а ставить не из deb уже боюсь. Не знаешь где взять deb поновее что бы.

И что ВООБЩЕ не желательно ничего ставить иначе как apt-get? %)

0 пользователя(ей) сказали спасибо:

#6
gabber
  • Статус: Administrator
  • Сообщения: 479
  • Карма: 0
  • Пол:
    Не указано
такие штуки ищуться на http://www.apt-get.org или опять же в списке рассылки, там такие вещи обсуждаются :)

а вообще я брал отсюда - работает и не жужжит.
добавь эту строчку в /etc/apt/sources.list

deb http://penguinppc.org/~daniels/sid/i386 ./


Linux = RuleZ

0 пользователя(ей) сказали спасибо:

#7
Xa
  • Статус: Гуру Общения
  • Сообщения: 175
  • Карма: 0
  • Возраст: 33
  • Пол:
Gabber, а ты маны писать не пробовал? В паре строчек объясниь что и как, и как надо! Спасибо!

Я вот когда ИксФри ставил с tgz там шрифты какие-то были кривые, а тут сразу как в winXP сглаживание красивое такое.

В общем спасибо еще раз!!

0 пользователя(ей) сказали спасибо:

#8
gabber
  • Статус: Administrator
  • Сообщения: 479
  • Карма: 0
  • Пол:
    Не указано
не пробовал :)

просто работа в качестве support помогает такие штуки писать :) практика и еще раз практика :)


Linux = RuleZ

0 пользователя(ей) сказали спасибо:

Пользователи читающие эту тему: 2

1 пользователь, 1 гость